Main Menu


Welcome Guest

Welcome, Guest. Please login or register.

Login with username, password and session length

Search

Author Topic: No Power - 170S Cab A  (Read 746 times)

0 Members and 1 Guest are viewing this topic.

Offline Stolzy40

  • Trade Count: (0)
  • subscriber
  • *
  • Posts: 15
  • Exterior Color: Red
  • Interior color: Tan
  • Location: Missouri, USA
  • VIN #: 13604216451
  • Year_Model: 1951- 170S Cab A (Kemp Auto Museum)
No Power - 170S Cab A
« on: August 21, 2010, 12:13:19 PM »
Got the 170s Cab A running for the Kemp Auto Museum. It starts well- not a problem. Resolved the flat spot on static acceleration by reworking the accelerator pump, resetting the timing and a couple other things - accelerates well when standing still.
Last week took the car out for a ride (BTW, the first time that's happened since the Museum owned the car). The car had absolutely no power. Could barely get it into 3rd gear. Things checked:
1. Dropped the exhaust system thinking there might be a blockage - no change.
2. Checked the fuel delivery system, pulled fuel pick up out of tank, checked operation of fuel reserve/off valve, made sure all fuel lines and filters were clean - no problem found.
3. Checked size of carb fuel jets and air jets - according the the Solex manual, car has correct jets.
4. Checked compression - 125 PSI across 4 cylinders.
5. Checked for air intake leak - no problem found.
I'm baffled. Anyone have any more ideas? I welcome to any suggestions.
BTW, the Museum has a 170 sedan with the same engine and that runs well. If fact it's peppy compared to the Cab A.
Thanks,
Mark Stolzenburg
Volunteer
Kemp Auto Museum

Offline mb170sb

  • Trade Count: (0)
  • subscriber
  • *
  • Posts: 12
  • Location: Norway
  • Year_Model: 1940 230 Bcab, 1952 220Acab, 1963 230SL, 1973 450SLC
Re: No Power - 170S Cab A
« Reply #1 on: March 18, 2011, 03:42:47 PM »
change the sparkplugs, sound as if they cannot take the load