Main Menu


Welcome Guest

Welcome, Guest. Please login or register.

Login with username, password and session length

Search

Author Topic: Ignition problem 1954 MB 170SV  (Read 733 times)

0 Members and 1 Guest are viewing this topic.

Offline Glenn170svNorway

  • Trade Count: (0)
  • subscriber
  • *
  • Posts: 11
  • Location: Norway, Finnmark, Alta
  • Year_Model: 1954 170S-V
Ignition problem 1954 MB 170SV
« on: May 20, 2016, 04:47:16 AM »
Hi

I got a problem with my 1954 MB 170SV. It is hard to start sometimes, but sometimes it starts at once i push the start button. And when i drive, it dosnt run as good as it used to. I think it only runs on cylinder 1,2 and 4, not 3.

I have changed the coil, new distributor cap and rotor, new condensator. The spark plugs look fine, so does the spark plug wire.

Any suggestion what the problem could be?

Best regards

Glenn Solheim
Norway, Alta.

Offline CraigS

  • Trade Count: (0)
  • member
  • ***
  • Posts: 471
  • My current project - Tatra 600 (Tatraplan)
Re: Ignition problem 1954 MB 170SV
« Reply #1 on: May 20, 2016, 05:43:41 AM »
Easiest way to check if it is running on all cylinders is to remove each spark plug lead with the motor running and see if there is a change in the sound - there should be. If one cylinder does not change, at least you know where to start. I would then do a compression test on that cylinder and also check the others. If the reading on the faulty cylinder is significantly less than the others, I would start by checking the valve adjustment.

Offline roadster36

  • Trade Count: (0)
  • member
  • ****
  • Posts: 637
  • www.mbchassisclub.nl
    • www.mbchassisclub.nl
  • Exterior Color: Blue
  • Interior color: Brown
  • Location: Netherlands
  • Year_Model: 170v roadster 1936 / 170v 2 door /170v 4 door1948
Re: Ignition problem 1954 MB 170SV
« Reply #2 on: May 20, 2016, 10:11:16 AM »
And clean the carburetor, and gasoline filters

Offline Henry Magno

  • Trade Count: (0)
  • member
  • ****
  • Posts: 838
  • Location: USA, Massachusetts
  • Year_Model: 1952 220 Cab B, 1937 320 Sedan, 1937 320 Combination Coupe, 1938 320 Cab A LWB
Re: Ignition problem 1954 MB 170SV
« Reply #3 on: May 20, 2016, 12:48:37 PM »
I would start by changing the plugs. Sometimes they look better than they are.

Offline 170Sb-Fahrer

  • Trade Count: (0)
  • subscriber
  • *
  • Posts: 3
  • Location: Germany
  • Year_Model: 1952 170Sb and VW 1300 (1965)
Re: Ignition problem 1954 MB 170SV
« Reply #4 on: December 25, 2016, 06:11:26 PM »
Hi,

The best way to detect this, is using an oscilloscope for car testing. Maybe you know somebody who has one. All spikes (for each cylinder one spike) should have the same height.

kind regards
170Sb-Fahrer